Lightweight extension for on-the-fly manipulation to primary selections, especially optimized for Dictionary lookups For support, please report any issues via the homepage link below.
Note: Binary files aren't shown on the web site. To see all files, please download the extension zipfile.
Version | Status |
---|---|
81 | Active |
80 | Active |
79 | Active |
78 | Active |
77 | Active |
76 | Active |
75 | Rejected |
74 | Active |
73 | Rejected |
72 | Rejected |
71 | Active |
70 | Inactive |
69 | Inactive |
68 | Active |
67 | Active |
66 | Rejected |
65 | Active |
64 | Inactive |
63 | Inactive |
62 | Inactive |
61 | Inactive |
60 | Inactive |
59 | Inactive |
58 | Active |
57 | Inactive |
56 | Inactive |
55 | Rejected |
54 | Inactive |
53 | Inactive |
52 | Inactive |
51 | Inactive |
50 | Rejected |
49 | Inactive |
48 | Rejected |
47 | Active |
46 | Inactive |
45 | Rejected |
44 | Rejected |
43 | Rejected |
42 | Rejected |
41 | Inactive |
40 | Rejected |
39 | Inactive |
38 | Inactive |
37 | Rejected |
36 | Inactive |
35 | Rejected |
34 | Rejected |
33 | Rejected |
32 | Rejected |
31 | Inactive |
30 | Rejected |
29 | Rejected |
28 | Active |
27 | Active |
26 | Rejected |
25 | Inactive |
24 | Rejected |
23 | Inactive |
22 | Inactive |
21 | Rejected |
20 | Rejected |
19 | Rejected |
18 | Rejected |
17 | Rejected |
16 | Inactive |
15 | Rejected |
14 | Inactive |
13 | Inactive |
12 | Inactive |
11 | Inactive |
10 | Inactive |
9 | Inactive |
8 | Inactive |
7 | Inactive |
6 | Inactive |
5 | Inactive |
4 | Inactive |
3 | Inactive |
2 | Inactive |
1 | Rejected |
I'm sorry but I have to reject this one again, because this is really hard to review. and I see multiple `eval`s in the code that I cannot find the possible string they are trying to evaluate. and we still having hard time to follow how you remove those timeouts with `Symbiont()`.
> and I see multiple `eval`s in the code that I cannot find the possible string they are trying to evaluate. These strings to be evaluated are provided by the user via the settings. > and we still having hard time to follow how you remove those timeouts with `Symbiont()`. Would it help if I changed `Symboint` to the following `SourceManager`? ```js export class SourceManager { constructor(host, removeSource, addSource) { host.connectObject('destroy', () => this.removeResource(), getSignalHolder(host)); this.addResource = (...args) => (this._delegate = addSource?.(...args)); this.removeSource = () => { removeSource(this._delegate); this._delegate = null; }; } refreshSource(...args) { this.removeSource(); return this.addSource(...args); } } ```
Yeah, it will be much better. It would be much nicer to see more readable code across all the lines. and for eval I cannot still tell that comes from gsettings.
> Yeah, it will be much better. It would be much nicer to see more readable code across all the lines. OK, please list other unreadable content that have to be changed. > and for eval I cannot still tell that comes from gsettings. I can only say that these strings are coded to be read from gsettings. If they were to come from somewhere else, I would also be curious as to where that might be. Do you have any feasible suggestions to make it easier to identify their source?
Maybe inside `getCommand()` (413 extension.js) we can have a more readable code. And it would be much better if `ldocr.py` could be hosted on `pip` as we mentioned in the review guidelines: https://gjs.guide/extensions/review-guidelines/review-guidelines.html#scripts-and-binaries btw, line 27 extension.js shouldn't be in global scope. It can be created inside `DictAct`.
>Maybe inside `getCommand()` (413 extension.js) we can have a more readable code. How about `return (name && this._scmds.find(x => x.name === name) || this._scmds[this.scommand]) ?? this._scmds[0];`? > And it would be much better if `ldocr.py` could be hosted on `pip` as we mentioned in the review guidelines: btw, line 27 extension.js shouldn't be in global scope. It can be created inside `DictAct`. Fine, the future uploaded version will not include `ldocr.py`.
Yes, it's better. Thanks!